Uploaded image for project: 'H5P'
  1. HFP-1874

Course Presentation - Slide names used as markers not working

    Details

    • Type: Bug
    • Status: Done (View workflow)
    • Priority: Medium
    • Resolution: Done
    • Affects versions: None
    • Fix versions: Gefjun
    • Labels:
      None
    • Environment:

      Content created in H5P.org

    • Sprint:
    • Acceptance Criteria:
      CP should still skip back to the marker slide.

      Description

      Notes from the user:

      I've created a 40-slide presentation with 4 sections of 10 slides each, so I have created 4 keywords for slides 1, 11, 21 and 31 which appear on the left navigation pane. It works fine except, for one thing.

      Let's say slide 11 is has 'Section 2' as its keyword. User navigates forward to slide 12, 13 or 14 (none of which have keywords). The user will expect that clicking on 'Section 2' in the navigation pane will return them back to slide 11 (the start of the section) but it doesn't - in fact it doesn't do anything. Clicking on any of the other 'keyword' titles in the navigation pane brings the user to specific slide that has that keyword (which is the first slide of that 'section).... except for the section you're in... where it doesn't do anything and you stay where you are. Is this how it is supposed to work, or is there a way of addressing it?

      Issue is reported here.

      Sample content.

        Attachments

          Activity

            People

            • Assignee:
              oliver.tacke Oliver Tacke
              Reporter:
              bv.h5p.forum Bienvenido Villadelrey
              Code reviewer:
              Frode Petterson
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: