Interactive Video - Video Quality not showing all options

Description

In Interactive Video not all video qualities are showing. When using the same videos the option changes depending on the order the videos are uploaded. Different browsers will also show different options. According to the OP the options also changes depending on the browser that was used to create the content although I am unable to reproduce this part of the issue.

I created 2 samples to show this issue. I used 4 files 2 WebM and 2 mp4 files. Mp4 files are labeled as "A" and WebM are labeled as "B", with numbers corresponding to the order they were uploaded.

Sample 1

I uploaded the WebM files first then the mp4 files:

https://h5p.org/node/802508

Sample 2

I uploaded the mp4 files first then the WebM files:

https://h5p.org/node/802516

More detailed tests are done by the OP with the information below:

In the meanwhile I did some testing which could turn out to be useful.
I prepared 2 very short movies (20” each), type A contains slide A and is .mp4, type B contains slide B and is .webm. They were both recorded and produced with Camtasia editor and saved as .mp4 originally, then B has been converted into webm.

I created 5 different h5p IV using safari and firefox editors (2x5=10 movies) on mac Mojave OS and different arrangements of content as follows (moviename = series type of content, named expected list in quality level)

S- A only = A, named A
S - B only = B, named B
S - A first = ABABAB, named A, B, A1, B1, A2, B2,
S - B first = BABABA, named B, A,B1, A1, B2, A2,
S - AABBAA = AABBAA, named A, AA, B, BB, A1, A1A1
FF - A only = A
FF - B only =B
FF - A first = ABABAB, named A, B, A1, B1, A2, B2,
FF - B first = BABABA, named B, A, B1, A1, B2, A2
FF - AABBAA = AABBAA, named A, AA, B, BB, A1, A1A1

Test page: https://medicina.i-learn.unito.it/course/view.php?id=349&notifyeditingon=1#section-35 please login as guest and open the activity named provarisorse.

I attached a screenshot comparing Chrome and Firefox. Edge on the other hand is consistent with what Chrome is showing.

More details are on the OPs post: https://h5p.org/node/751128/

Environment

None

Acceptance Criteria

None

Assignee

Unassigned

Reporter

Bienvenido Villadelrey

Labels

None

Funding

None

Code reviewer

None

Released

None

Time tracking

0m

Fix versions

None

Sprint

None

Priority

Medium
Configure