Fix upgradescripts: Summary and SCS

Description

When upgrading IV I got an error saying:

For CPI got an error related to SCS saying:

For summaries error:

The upgrade scripts will crash for h5p content that does not have parameters.summaries defined in Summary, and for SCS's that doesn't have options.choices, when trying to get the length of these arrays.

Acceptance Criteria

-

Assignee

Tom Arild Jakobsen

Reporter

Thomas Marstrander

Labels

None

Funding

Opigno Autumn 2016

Code reviewer

None

Released

None

Fix versions

Priority

Medium
Configure