We're updating the issue view to help you get more done. 

Improve error message when uploading content with new libraries

Description

The current error message when a user without permission to install libraries uploads an H5P containing a new library is:

Could not validate H5P file.

Make sure the uploaded H5P contains valid H5P content. H5P files containing only libraries should be uploaded through the H5P Libraries page.

Acceptance Criteria

1. Better error message when uploading content that includes a new library and you don't have permission to install libraries.

"
You're not allowed to upload this H5P file,

The content you're uploading contains a new H5P library. Contact your system administrator and ask him to consider installing the file."

Status

Assignee

Unassigned

Reporter

Svein-Tore Griff With

Funding

None

Code reviewer

None

Released

None

Time Tracking

16h

Priority

High